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Introduction 
About the Instructor 

Jesús Ramirez is a digital graphics expert, speaker, and educator 
specializing in Adobe Photoshop. Jesús is best known as the 
founder of the Photoshop Training Channel, one of the most 
popular Photoshop YouTube channels in the world.  

Jesús has been a speaker at Adobe MAX, Adobe SUMMIT, 
Adobe MAKE IT, CreativeLive, CreativePro and many other 
conferences and industry events. He is also a content creator for 
the Adobe Creative Cloud Blog, and many other design and 
photography websites. 

Email: jr@ptcvids.com 
Website: ptcvids.com - videosptc.com (Spanish) 
Behance, Instagram, & Twitter: @JRfromPTC 
YouTube: youtube.com/user/photoshoptrainingch  

Lab Project Files 
Your computer should have a folder titled “L417_Ramirez.” This folder will contain all 
the files that we will use for this lab. 

Lab Objectives 
The objective is for you to learn and practice techniques that professionals use to 
transform and enhance their photographs.  

Lab Description 
This information-packed lab will teach you key techniques for turning your photos into 
eye-catching images. You’ll work step-by-step from original photos to finished images, 
and practice skills and techniques that professionals use that you can apply to your 
photographs immediately. You'll also learn handy tips and tricks that save time and help 
you create your best work. 

This session will demonstrate how to: 

• Remove distracting elements from photos 
• Make targeted color adjustments to get best results when removing color casts 
• Make your dull photos pop with color and tonal adjustments 
• Create realistic sky replacements to improve your photos with dull skies 
• Construct convincing composites to solve photo challenges 

https://www.youtube.com/user/photoshoptrainingch
mailto:jr@ptcvids.com
https://photoshoptrainingchannel.com/
https://videosptc.com/
https://www.youtube.com/user/photoshoptrainingch
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Removing Distracting Elements 
from Your Photos 
When it comes to eliminating objects in your pictures, nothing beats the power of 
Content-Aware in Adobe Photoshop CC.  

Content-Aware allows you to use surrounding pixels to generate new ones to cover the 
unwanted object. It all happens seamlessly, and it doesn’t require expert Photoshop 
skills to remove undesirable elements from your photos 

In the following two projects, you will learn to use the Content-Aware Fill, and the Spot 
Healing Brush tool to remove distracting elements from your photos. 

Content-Aware Fill 
In this first project, you will learn to use Content-Aware Fill to remove unwanted 
objects from a photo. 

The Content-Aware Fill analyzes the area that you select, and it replaces the unwanted 
object with similar nearby pixels. It’s a great and simple solution that can generate 
realistic results without much work. 

Removing Objects Using Content-Aware 
To Remove an unwanted object from a photo using Content-Aware Fill, first select the 
object using the Lasso Tool (L). You can draw a loose selection around the car to select 
it. You do not have to be very precise. 

 

With the selection active, go to Edit > Fill.  

In the Fill dialog box, under Contents, select “Content-Aware.” Make sure that you check 
the Color Adaptation and press “OK.” 
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Note: Color Adaptation algorithmically blends the color of the fill with the surrounding 
color. 

Photoshop will then fill the image with pixels similar to those surrounding the selection 
and remove the unwanted object. 

 

Advance Method – Layer Masks 
As incredible as the Content-Aware Fill is, sometimes it chooses the wrong areas to 
sample from, and it fills with unwanted elements into your photo.  

In the example below, you can see how Photoshop used trees and lampposts as sample 
sources and used those elements in the fill.  
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Luckily, Photoshop allows you to select what areas to sample from when performing a 
Content-Aware Fill. 

Photoshop only analyzes visible pixels so you can use a Layer Mask and restrict what 
Photoshop can sample from when generating the fill.  

Using the Lasso Tool (L), select the area 
around the van. Then select similar 
surrounding street areas.  

With the selection active, click on the 
Layer Mask icon in the Layers panel to 
create a Layer Mask that only reveals 
the items you selected. 

Using the Lasso Tool (L), select the van, 
and apply the Content-Aware Fill.  

Note: To save some time, you can load the saved selection embedded in the document. 
Go to Select > Load Selection and under the Channel drop-down menu select “Van.” 

Make sure that the focus (white outline) is around the Layer thumbnail and not the 
Layer Mask thumbnail. 

 

Delete the Layer Mask, and voila! No more van! 
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Working with Color 
Removing Color Casts 
A color cast is an unwanted tint in the image due to the lighting, the white balance of 
the camera, or the lighting conditions during the shoot.  

Color casts exist because one or more RGB (Red, 
Green, Blue) color channels is either too strong 
or weak. Color casts are more noticeable in areas 
that should be a neutral gray.  

In RGB, neutral colors always have similar RGB 
values. This is not the case in images with color 
casts. The neutral colors always have too much 
or too little of one color channel. 

If you examine an image with a color cast, like 
the food truck, with the Histogram, you will see 
the disproportionate levels of each channel that 
cause the color cast.  

As you might imagine, there are a lot of ways of 
neutralizing images in Photoshop. But one of the 
best tools to use is the Curves Adjustment Layer.  

Using Curves to Remove a Color Cast Automatically 
Curves (and Levels) has a button that automatically lets 
you remove color casts from your photos. But you need 
to change the algorithm so that it works the way that 
you would expect.  

When using a Curves Adjustment Layer, in the 
Properties Panel, you will see an “Auto” button. You can 
click on it to perform an automatic adjustment.  

In some cases, the default algorithm may not give you 
the best results. You can change how the automatic 
button works by changing the algorithm that it uses.  

To change the button’s settings, hold Option (Window: 
Alt), and click on the Auto button. 
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In the Auto Correction Options dialog box, you will see a choice of four algorithms.  

 

For removing color casts, try using the “Find Dark & Light Colors” algorithm. Make sure 
to also check the “Snap Neutral Midtones” Checkbox. 
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Applying Creative Color Corrections 
Sometimes, instead of removing color casts, you might want to add a color grade (or 
creative color correction) to your photo to help you tell a story.   

There are no rules as to what colors should be used, or how they should be used.  The 
choice is entirely up to you and the story that you are telling with your photograph.  

But you should always perform a color correction first so that it is easier to apply a color 
grade. 

Color Lookup Adjustment Layer 
One of the Adjustments Layers that allows you to apply color grades automatically is the 
Color Lookup Adjustment Layer. This Adjustment Layer gives you a list of presets known 
as lookup tables or LUTs.  

LUTs are used in the film industry to apply color grades to film, but you can use them in 
Photoshop to apply different styles to your photos. Think of them as filters as something 
like an Instagram filter. 

To apply a Lookup Table Adjustment Layer, go to Layer > New Adjustment Layers > 
Color Lookup. 

Then scroll through the list of LUTs to see the different color effects that are available. 
(Under “Load 3D LUT…”) 
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Compositing Images Together 
Compositing is the combination of visual elements from separate sources into a single 
image, often to create the illusion that all those elements are parts of the same scene. 

In the projects for this lab, you will learn to use tools that allow you to combine images 
better and faster. 

Sky Replacements 
In this project, you'll learn how to easily replace the sky in photos that contain dull or 
gloomy skies. 

The Photoshop document for this project contains two layers. A photo of the 
Teotihuacan Pyramids, and an Adobe Stock image of clouds. 

Blend the Sky Layer to The Background 
To make the sky layer blend with the pyramids image, you could try using layer masks, 
but sometimes they either take too long to make or are not accurate enough. 

Instead, look at the Advanced Blending options in the Layers Style dialog box. From 
there, you can use the Blend If options to blend images using the luminance values of 
the image or each RBG channel.  

Select the Sky layer and double-click on the side of the layer name to bring up the Layer 
Style window. Then select “Blue” under the Blend If dropdown.  
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On the “Underlying Layer” option, click-and-drag the Black Point to the right to hide 
pixels that contain very little blue.  

Then hold Option (Windows: Alt) and click on the Black Point handle to split it in half. 
You can then drag each point independently to create a smoother transition between 
visible and invisible pixels. 

Brighten The Sky 
After you apply the blend, the image will look off. This is because the new sky is much 
darker than the original. To make it more realistic, you can brighten it up by using an 
Adjustment Layer. 

Create a Levels adjustment layer and drag the midpoint slider to the left to brighten up 
the image until the sky matches the rest of the phot. 
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Window Reflection 

 

This effect will create the illusion that the photo was shot through a glass window.  

This technique helps give your photo a bit more depth and emotion. Even if you never 
intend to fake reflections in Photoshop, this project is a great crash course in how 
Blending Modes work, and how to use Adjustment Layers to control how they blend. 

Use Blending Modes to Create a Reflection Effect 
Before making any adjustments, right-click on the Busy City layer and convert it into a 
Smart Object. You always want to work non-destructively. 

Then change the Blending Mode to Lighten. 

 

The Lighten Blending Mode looks at the base color and blend color, and it keeps 
whichever one of the two is the lightest. If the blend colors and the base colors are the 
same, then no change is applied.  

The resulting blend is very similar to what a window reflection might look like in real life. 
However, you will need to reduce the Busy City’s Opacity to make it a bit more realistic. 

Blur the City Image 
Notice the shallow depth of field of the original image. If this were a real photo, the 
window reflection would also have the same blur. Apply the Gaussian Blur Filter to 
match the blurriness of the image.  
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Adjusting the Blend 
Remember that most Blending Modes use luminosity to determine how they blend. 
That means that you can adjust the blend in this image by using adjustment layers that 
control luminance.  

For example, you can use as Levels Adjustment Layer that is clipped to the Busy City 
Layer to control how it blends. 

Another useful technique is to clip a Black & White Adjustment Layer to the reflection 
layer. Then set the Blending Mode to Luminosity and adjust the luminance values of 
specific colors to conceal or reveal them. 

Applying a Texture to Create a Stained-Glass Effect 
Perfection doesn’t exist in the real world. Even the cleanest windows should have some 
smudges or stains.  

Use the “Dirty Surface” Layer to create a texture that will add stains to the window. 

You don’t need to worry about creating complicated masks. Use the “Blend If” sliders in 
the Layers Styles window to selectively hide bright pixels and keep the dark ones. 

 

You can then set the Layer to Multiply and bring the Opacity down to 5%. 
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Creating Highlights and Flares 
Some windows may have highlights or flares reflecting on them.  

Start by making a new layer and with a soft brush, paint a large white dot in the center. 
The change the Blending Mode to Color Dodge. 

Color Dodge Blending Mode, which is one of the eight special Blending Modes in 
Photoshop that gives your different results when you adjust Opacity compared to Fill.  

These eight Blending Modes also blend differently when the “Transparency Shapes 
Layer” checkbox is unchecked in the Layers Style window. 

Note: The eight blending Modes are: Color Burn, Linear Burn, Color Dodge, Linear Dodge 
(Add), Vivid Light, Linear Light, Hard Mix, and Difference. 

 

Notice how the white pixels blend differently, making it look more like a bright highlight. 
You can then reduce the intensity of this highlight by decreasing the Fill. 
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Color Grade the Image (Creative Color Correction) 
Use a Selective Color Adjustment Layer to apply a color grade to the image. Select the 
Blacks from the Dropdown, and adjust the color sliders to change the look of the image. 
You can start by adding cool colors to the Blacks.  

 

Then repeat this process with the neutrals. 
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360 Spherical Panoramas 
Photoshop CC 2018 can now edit equirectangular spherical panoramas in 3D space.  

One device that generates such images is the Ricoh Theta, which is the camera use to 
take the photo that we will use for this lab. 

Opening a Spherical Panorama in Photoshop 
To open a spherical panorama in Photoshop, go to File-> Open and select your image.  

With the spherical panorama loaded and its layer selected in the Layers Panel, go to  
3D > Spherical Panorama > New Panorama Layer from Selected Layer. 

Note: Currently, Photoshop can only handle equirectangular spherical panoramas. 

Rotating the Camera View 
First, you can rotate the camera view around.  

With the Move Tool selected, you can click-and-drag anywhere over the image, which 
will allow you to look around inside the panorama. 

You could also rotate the image using most tools by clicking-and-dragging on the Orbit 
Camera Icon found in the Axis widget, in the lower-left corner of the document view. 

 

Clicking-and-dragging on this icon will rotate the camera without having to switch back 
to the Move Tool. 
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Editing Spherical Panoramas 
All the Photoshop painting tools and filters will work on the view shown in the 
document window.  

Note: Filters will only affect the area currently being seen. 

If you wish to run a filter on the entire panorama, you need to first open the source 
panorama by double-clicking on the texture label in the Layers Panel. 

Non-Destructive Workflow – Target Textures 
The problem with painting directly over the 
Spherical Panorama is that you destroy the 
original pixels.  

To work non-destructively, open the 360-
pano texture by double-clicking on it from 
the Layers Panel.  

Then create a new blank layer. MAKE SURE 
that the selected layer is the new empty 
layer (this will make it the Target Texture), 
then save and close the tab.  

Back in the Spherical Panorama view, you 
can paint directly over the panorama, and 
any adjustments that you make will be 
applied to the blank layer and not the 
original image. 

Merge Down Feature 
You can create a new layer on the spherical panorama view, and paint anything that you 
like on it. To apply it to the spherical panorama, press Command E (Windows: Ctrl E). 

You could also use this method to apply text to the panorama. You can use the Type 
Tool to apply your text, then press Command E (Windows: Ctrl E) to merge the text 
down into the Target Texture.  

Remember always to have a blank layer set as your target texture (See the previous 
step). 

Exporting the Spherical Panorama 
The final step is to export the panorama. Use the Export Panorama feature from the 3D 
menu to make sure that you keep all the metadata required to create a Spherical 
Panorama. 
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